From where to download the pre-install edge impulse .hex on thingy53

I am in trouble, I have a thingy53 which I previously used as a Bluetooth peripheral, but now my needs are changed and I need to use edge impulse on it.
But the problem is I don’t have the pre-installed edge impulse(which is already flashed on the board when shipped), and now, I tried very hard but your edge impulse is not working on it.

I have used multiple samples provided by nordic like Machine Learning Application so that your daemon accepted it but unfortunately, it only needs that already pre-flashed new board.

I am following this official link:- Nordic Semi Thingy:53 - Edge Impulse Documentation

I have used the from step 2, but it is still not working.

Now, my humble request for you is, can you please provide me with the dfu/hex of that which is pre-installed in the board when shipped?

Hi, this is links

1 Like

I am encountering an error while trying to download the deployment data from the Edge Impulse API for my project. The error message I receive is as follows:
error: downloading ‘’ failed
status_code: 22
status_string: “HTTP response code said error”

I have checked my internet connection and made sure that I have the correct API key for my Edge Impulse project. I have also tried accessing the URL in my browser to see if I can download the deployment data manually and it is downloading, but I am still unable to resolve the issue.

Could you please help me resolve this issue so that I can continue with my project? I would greatly appreciate your assistance.

I am using the machine learning sample from NCS, here is the screenshot for more clarity.

I think maybe this error is due to this

But I don’t know how to provide the API key, I followed the official doc Using Edge Impulse with the nRF Connect SDK — nRF Connect SDK 2.2.99 documentation

but still don’t know how to add it in cmake option.

Note: I know you will suggest Modifying an application — nRF Connect SDK 2.2.99 documentation this but I still don’t know how to do that.

I have resolved the API key issue.
So now the build is successful and the library is downloaded then added to the code

But when I run the edge-impulse-daemon command on cmd, after providing credentials, when it moves to select port

I am facing the problem that it is not connecting to board instead it stays at “Connecting to COM17” for some time and then shows the “Failed to connect to COM17 retrying in 5 seconds Open (SetCommState): Unknown error code 121” this error
please help

Hi @bertm

Are you on Windows? I think this is possibly a drivers issue. Not 100% sure, if you are on windows i can try to find out.



Yes Windows 11, no it’s not a driver issue.
Please go through my Devzone ticket for more clarification and help me.

Hi @norik.badalyan @bertm

To restore your Thingy53 to Edgeimpulse Firmware you can follow the steps on our Github Firmware Readme for the Thingy53:

If you encounter issues with this process please ping screenshots and details in here and I will attempt to try to reproduce.

On the nordic side, from reading through your issue on the nordic forum, it appears like a step was missed. Its hard to tell where though.

If you follow their Session 1 tutorial in either video or written format to reinstall the Nordic Connect SDK tools and vscode plugins. Taking care to choose the correct versions for the associated chip in the Thingy53 namely the nRF5340 SoC should get you set up correctly:

Hope this helps,



1 Like

hello i had no problems but thank you

1 Like