Flashing the Board nRF9160 DK is not possible

Hello everyone,
I have been trying to get the nRF9160 DK connected to Edge Impulse Platform but it is not possible. i have been following this viedo Connecting nRF9160 DK to Edge Impulse - YouTube for connecting the Dk to the Platform.

after flashing the application and tyring to run this command edge-impulse-daemon
i am still getting this output

C:\Users\USER>edge-impulse-daemon
node:internal/modules/cjs/loader:998
throw err;
^

Error: Cannot find module ‘C:\Users\USER\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\cli\daemon.js’
at Module._resolveFilename (node:internal/modules/cjs/loader:995:15)
at Module._load (node:internal/modules/cjs/loader:841:27)
at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)
at node:internal/main/run_main_module:23:47 {
code: ‘MODULE_NOT_FOUND’,
requireStack: []
}

Node.js v18.12.1

C:\Users\USER>

so what should i do to get the DK connected to Edge Impulse ??
i would be sp happy for your help.

Many thanks
Obaida

If daemon.js file is not there then you probably have not installed the Edge Impulse Command Line Interface (CLI). CLI install instructions are here.

Hey,
first of all many thanks to your answer. unfortunately i am still not able to connect the DK to the Platform.
after installing the CLI that was the output :

then i did exactly like what was in this viedo Connecting nRF9160 DK to Edge Impulse - YouTube

and after flashing the board , that was the output :

after running the command edge-impulse-daemon that was the output :

after choosing the first COM like the video description that was the output:

and at the end there is no connection between the DK and the paltform.

would you please just tell me , what should i do anymore ??

all programmed have been installed but unfortunately i cant get any connection until now.

I would be super happy for any other informations.

Best Regards
Obaida

In Windows Device Manager is your nRF9160 listed under Ports (COM & LPT) as COM5?

So the CLI is now installed correctly! :clap:

Also, just a quick question, are you using the X-NUCLEO-IKS02A1 extension shield? It is mandatory to use this one to connect the board using edge impulse default firmware.

I remember I ordered the wrong one when I first tested it more than a year and a half ago and I ran into a similar issue.

Also this board is a bit capricious, see Nordic Semi nRF9160 DK - Edge Impulse Documentation.

Best,

Louis

Hey, actually you can find all ports here and i have no idea which port should i choose in this case ? would you please tell me !!

i think i have ordered the wrong one instead of [X-NUCLEO-IKS02A1] i ordered this one
[X-NUCLEO-IKS01A2] !!!

Arf, I did the same mistake :slight_smile: