Flashing problem Arduino 33 BLE Sense Linux


I am a beginner to edge impulse…
I’m not successful flashing the device with the edge impulse firmware.

This is what i have already tried.

  1. sudo chmod a+rw /dev/ttyACM* sudo chmod a+rw /dev/ttyACM0
  2. Updating udev rules
  3. Resetting the device again
  4. Loading the firmware again
  5. edge-impulse-run-impulse --raw
    After a lot of messages saying failed to connect… it connects eventually and then no messages. Last message was
    [SER] Connected to /dev/ttyACM0

I think the firmware itself is not successfully installed. Because when i run the .sh file. The terminal shows commands like…
Nano 33 BLE Sense OK…
AND THEN IT CLOSES… IT SAYS NOTHING AFTERWARDS! It happens so fast that i even couldn’t see the terminal properly.

Please guide me with the issue…

Hello @rida ,

Can you try to use another USB cable?
Which OS are you using?

If last message was [SER] Connected to /dev/ttyACM0 when using the edge-impulse-run-impulse --raw command, can you try to type AT+RUNIMPULSE ending by a carriage return.



And can you flash one of the provided Arduino example from the Arduino Library?

Thanks for your response!

I have used 2 usb cables so far
I’m using Linux
What is carriage return? (sorry for the silly question)

I have tried flashing examples from arduino… it works fine. UPloads… gives me details of the board

Ubuntu to be precise

I managed to solve it by installing an older version of arduino cli…
the previous version was 0.23.x
I tried downloading 0.18.x
The board has been successfully flashed!


1 Like