Fails to install edge-impulse-linux

npm WARN deprecated request-promise@4.2.4: request-promise has been deprecated because it extends the now deprecated request package, see
npm WARN deprecated request@2.88.0: request has been deprecated, see https://github. com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See for details.
npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github. com/visionmedia/debug/issues/797)
/usr/bin/edge-impulse-linux -> /usr/lib/node_modules/edge-impulse-linux/build/cli/linux/linux.js
/usr/bin/edge-impulse-linux-runner -> /usr/lib/node_modules/edge-impulse-linux/build/cli/linux/runner.js
/usr/bin/edge-impulse-camera-debug -> /usr/lib/node_modules/edge-impulse-linux/build/cli/linux/camera-debug.js

> sharp@0.29.1 install /usr/lib/node_modules/edge-impulse-linux/node_modules/sharp
> (node install/libvips && node install/dll-copy && prebuild-install) || (node install/can-compile && node-gyp rebuild && node install/dll-copy)

sharp: Installation error: Use with glibc 2.28 requires manual installation of libvips >= 8.11.3
sharp: Please see for required dependencies
npm WARN tsargs@1.4.1 requires a peer of typescript@^3.1.6 but none is installed. You must install peer dependencies yourself.

npm ERR! errno 1
npm ERR! sharp@0.29.1 install: `(node install/libvips && node install/dll-copy && prebuild-install) || (node install/can-compile && node-gyp rebuild && node install/dll-copy)`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sharp@0.29.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2023-10-24T16_33_50_453Z-debug.log
1 Like

Greetings Elon and welcome to our forum :artificial_satellite: :rocket: :rofl:

Not much context here for us, but you appear to be having trouble with your sharp installation? or some other environmental issues?

We have not had much report on Sharp so you would be best to verify your installation first:
sharp - High performance Node.js image processing.

Once that is fixed try to quickly remove and install our cli with the following:

npm uninstall -g edge-impulse-cli
npm install -g edge-impulse-cli

If you still experience issues. Then you will need to follow through our cli installation guide again and make sure all of the dependencies are installed correctly: