Failed to run classifier on 33Ble Sense

Hi there,

I tried to deploy multiple impulses on the Nano 33 BLE sense and I get the same error every time. I have also used Platform IO in one instance to see if it would work like that. Both times I get the same error.

Starting inferencing in 2 seconds…
ERR: Would write outside feature buffer
ERR: Failed to run classifier (-5)

I tried to increase the EI_CLASSIFIER_NN_INPUT_FRAME_SIZE but with no result. I think the problem is somewhere else.

Project ID: 24459

Thank you

Hi @cristiansulighetean,

I will take a look at your project

1 Like

There are 2 processing blocks in your design. But only 1 of them is connected to the learning blocks. Still both of the blocks are being deployed. This results in the feature buffer being too small. We will add a check in our code to prevent adding unused processing blocks.

For now you can simply remove the Spectrogram block.This should fix the issue.


Now it works if I delete the unused processing block.
Thank you!