Failed to connect to serial port (Raspberry Pi Pico)

Hi everyone, this is my first time posting a question here.

Before I drag the firmware into the storage of my Raspberry Pi Pico, its serial port is COM3.
When I run : edge-impulse-data-forwarder, it works fine:

When I run : edge-impulse-run-impulse, it will show as the picture below:

I know this will happen because I haven’t move the firmware inside the Pico. So, I drag the firmware of my project into the storage of my Pico. However, the serial port will change to COM5 and the command edge-impulse-run-impulse cannot connect to that port.

The same problem happen when I try to setting up device for edge impulse.

So, may I know how to solve this? Before Edge Impulse support Raspberry Pi Pico, I select ‘Arduino Library’ for deploy the impulse and it works fine. Now I want to try different method to deploy the impulse. Data forwarder also work fine if I not dragging any firmware into my pico.

1 Like

I also have same issue, did you find solution for this, please advice

Hi @kcwong and @Arunselva,

This appears to be a known issue with the Edge Impulse firmware for the RP2040 on Windows. A fix should be in the works. Please keep an eye on this GitHub issue for further updates: Serial comms hang in Win10 · Issue #1 · edgeimpulse/firmware-pi-rp2040 · GitHub