Failed to connect Edge Impulse from OpenMV IDE

Hi experts,

Tried to connect OpenMV to Edge Impulse, I got 『SSL context() error』 when tried to login from Open MV IDE. And got the following messages from terminal by edge-impulse-daemon.

Please kindly point out, if I missed anything, thanks.

@KXCY you’re in China right? Can you access the Studio over HTTPS from a browser?

Yes, I can access directly, without any VPN / Proxy. Furthermore, my Arduino nano works well.

I have the same issue, have changed firewall settings in Windows Defender (Windows 10). Did not help.

Hi @noone, unfortunately we can’t fix this as it’s an error in the OpenMV IDE. You can use the Edge Impulse CLI to upload your datasets as well, see the ‘Upload data from OpenMV datasets’ section in our docs:

Or you can upload using the Studio by going to Data acquisition > Upload icon.

Ah, ok. Are they at OpenMV aware of this error?
At the response is: “This is because of your network connection blocking SSL traffic to their server. Please check your firewall settings on your computer and network.”

Well, that’s all I can make of it as well.