Error while installing recent version of EdgeImpulse CLI

So this is the error while installing the recent version of EdgeImpulse CLI on Raspbian Buster 10

The previous version is working perfect though, and there is no specific need of the latest version, but reporting the error faced -

npm notice 
npm notice New minor version of npm available! 7.5.4 -> 7.6.3
npm notice Changelog:
npm notice Run npm install -g npm@7.6.3 to update!
npm notice 
npm ERR! code 127
npm ERR! path /home/pi/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/sharp
npm ERR! command failed
npm ERR! command sh -c (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
npm ERR! info sharp Using cached /home/pi/.npm/_libvips/
npm ERR! prebuild-install WARN install No prebuilt binaries found (target=3 runtime=napi arch=arm libc= platform=linux)
npm ERR! sh: 1: node-gyp: not found

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2021-03-12T13_18_25_126Z-debug.log

Can you attach the debug log? A couple of basic things to try:

  1. Make sure nodejs and python are installed
  2. run npm uninstall and then install again


npm ERR! sh: 1: node-gyp: not found

This is a weird error… Where did you get your Node.js installation from?

I don’t know how I missed the notification. Thanks for your reply. So, I followed and documented a process for installation for Raspbian, here -

The installation command was -

$ curl -sL | sudo -E bash -
$ sudo apt-get install -y nodejs

The earlier version of EdgeImpulse CLI released during Himax vision board, for live view of data from the board works just fine. This has some build errors.

No hurry on this, since the previous version is still usable. But wondering what’s the error

I did not change PATH or did not make any changes these days, but today, it installed perfectly to v1.12.5. Really weird.

Log -

$ npm install -g edge-impulse-cli

removed 1 package, changed 27 packages, and audited 313 packages in 2m

18 packages are looking for funding
  run `npm fund` for details

2 low severity vulnerabilities

Some issues need review, and may require choosing
a different dependency.

Run `npm audit` for details.

Thanks for your help @yodaimpulse @janjongboom

@dhruvsheth Thanks again, we’re going to be releasing a version of the CLI that does not depend on sharp for v1.13 - we’ve seen some other issues on Apple M1 too.

1 Like