Error setting up Jetson Nano with a CSI Camera

I’m trying to set up my Jetson Nano with the tutorial in the documentation website but I have a problem when I try to log because there is the error message “Failed to initialize linux tool Error: Cannot find any webcams, run this command with --disable-camera to skip selection”. The problem here is that I don’t know how to configure my csi camera to be recognize by edge impulse. Someone can help me plz?

Hi @Tony_F, also commenting here besides our email conversation for visibility to the rest of the community. As I read it only the Raspberry Pi Camera 2 is supported out of the box, other cameras (including the HQ one) require a driver and a hardware modification to work on the Jetson Nano.


1 Like

Hi @janjongboom, thank you for your answer here too, actually I have the RaspBerry Camera 2.1, according to descriptions of the product, it’s the same as the Camera 2. Then if the RaspBerry Camera 2 is supported do you know how can I do to use it?

@Tony_F Could you list the output of:


? It should list the camera there if it’s recognized.

@janjongboom I ran the command but the camera isn’t in the list.

In that case I’m not sure… Do you have any way of validating whether the camera works through a different application? I doubt it though, gst-device-monitor will at least list something in that case.

Also, are you sure the orientation / connection of the camera is correct?

Actually, I’m using the camera on some Python face detection projects in which it’s working very well.

@Tony_F I’ve ordered a V2 camera now, hopefully that will give us some clues!

@janjongboom ok thank you let me know if you find something. I’m continuing my research and if I find something I’ll let you know.

@Tony_F OK so NVIDIA has some proprietary plugins on top of GStreamer to deal with CSI cameras… I’ll try and get a patch out today!

1 Like

@janjongboom OK thank you let me know when you have something

@Tony_F v1.2.5 of the Edge Impulse Linux CLI has now been published which has the fix for this! You can update via:

npm update -g edge-impulse-linux

@janjongboom thank you so much it’s working !!! :grin:

@janjongboom thank you foryour help but I have another problem but this time it’s an error that appears during the python SDK installation. :sweat_smile:

Can you try without --upgrade?

I already tried it but it’s the same issue

Ho @Tony_F,

Can you check pip is pointing to python 3? pip -V
You cal also try with pip3.


Hi @aurel,
Thank you for your help, I have pip v21.1.1 installed and I also tried with pip3 and it doesn’t work too.

Can you provide the full output of pip -V?

Should be like: pip 21.1.1 from /usr/local/lib/python3.7/site-packages/pip (python 3.7)

Also just to verify the internet connectivity, see if you can ping pypi’s server:



As you can see I have the same result and the ping is working