Error microphone XIAO52840 Sense for data acquisition

When connect the XIAO microphone with “edge-impulse-data-forwarder” and try to use data acquisition i get the error: Invalid data collected from device. Also on Collect data section i see Sensor: Sensor with 1 axes Frequency: 2646Hz

Project ID:252666

Context/Use case:

did you ever use the webusb feature for testing?

i tested it with the example: arduino mic_serial_plotter, connected at the usb to com port and worked ok. is it the webusb?

WebUSB is under the USB icon on the Data Acquisition page in the Studio.

1 Like

Thanks, but i got error: Failed to connect to device
Error: Timeout when waiting for > (timeout: 5000) onConnected Are you using a device that is fully supported by Edge Impulse, and have you loaded the latest device firmware?

I checked the logs of edge-impulse-data-forwarder but i do not understand it.

can you please help me?

There are two connection methods in edge impulse.
1 - Usb serial terminal (cli) something you already did.
2 - WebUSB, according to the friend’s print above.

You will have to choose between one connection or the other, otherwise you will get timeout.

I tested Seeed xiao ble sense with this link, audio only and it worked perfectly Motion Recognition based on Edge Impulse | Seeed Studio Wiki
Tomorrow I can test the axes and try to reproduce the error, I’ll come back here with the results.

1 Like

Yes that’s right. I followed the steps on the web Motion Recognition based on Edge Impulse | Seeed Studio Wiki and the accelerometer works fine, likewise the microphone with PDM Microphone Usage on Seeed Studio XIAO nRF52840 Sense | Seeed Studio Wiki. Now, when I try to acquire data in edgeimpulse for a project with “edge-impulse-data-forwarder” with the 6-Axis IMU it works ok, but in another project, for sound classification, I get the error in the above image.

On the other hand, when I try to collect data using WebUSB I get the error “Failed to connect to device
Error: Timeout when waiting for > (timeout: 5000)”. Thanks you

friend, I managed to reproduce the same error, both in linux and in windows, I don’t know how to solve it, unfortunately, I already used this board in the Arduino IDE, the first time I try it in Edge, maybe there is an incompatibility, Overview - Edge Impulse Documentation, as you are trying to collect sound, I think the way out would be for you to collect it in another way and import the .wav file into Edge and then try to compile. If it works, please report.
I’ll leave the problem for edge experts to try to help!


Hi: thanks a lot for your help. I will try another way to collect sound data and will report it.

1 Like