Error installing edge_impulse_linux

I tried to install the linux SDK with pip3 install edge_impulse_linux, when this error occurred:

When I try to run the image example “” it shows following error:

ModuleNotFoundError: No module named ‘edge_impulse_linux’

Thanks for the help in advance!

Regards Jonas

Hi @HTWG_Elite, I have run into something similar on my mac and it had something to do with installing pyaudio. Until that completed successfully, I got the same ModuleNotFoundError. Try:

sudo apt-get install python-pyaudio

and see if this helps. There are also other suggestions on the web if you search for “fatal error portaudio.h not found raspberry pi”

Hi @yodaimpulse,
unfortunately “sudo apt-get install python-pyaudio” doesn’t work…
I installed pyaudio via…

sudo apt-get install libasound-dev
cd portaudio

… succesfully.
When I try “pip3 install edge_impulse_linux” again, I still get the same error. If I understand that right, what the error shows, it couldn’t include “portaudio.h”. This file however is installed.
I have no clue how to fix that problem.

Hi @HTWG_Elite,

Just to confirm, have you installed all dependencies first?

$ sudo apt-get install libatlas-base-dev libportaudio0 libportaudio2 libportaudiocpp0 portaudio19-dev
$ pip3 install edge_impulse_linux -i


just run this command

sudo apt install portaudio19-dev

it installs package and dependencies automatically