Error during compiling - Arduino Nano 33 BLE

I got this error during compiling an edge impulse’s library example with Arduino IDE 1.8.13.

Any idea on how to fix this?

Note: Previously, I got this error: “The filename or extension is too long”. Then, I managed to solved it by adding the platform.local.txt file as suggested by Jan Jongboom. Thanks Jan.

Did you add two different versions of the same library to you Arduino IDE named - industrial-motion-classifier-nano33blesense_inference.h. I am not pretty sure, but the logs read that. If you have two duplicated versions of the file, could you try removing the previous one and using the one compatible and try again?

If the file isn’t duplicate and instead, there are two libraries of the same name, you could try removing the one you don’t require, or rename it.

The duplicate libraries should not be a problem, Arduino takes the latest.

The unrecognized option error is the culprit, but I can’t see the exact message. My first guess would be that you’ll need to update the Arduino core for the Nano 33 BLE Sense via Arduino IDE > Tools > Board > Boards manager and then start by selecting 1.3.1 of this package:

(I see that Arduino has changed the cores again, so we should do some testing on our end, but that’s another story)

1 Like

Thank you @dhruvsheth and @janjongboom for the suggestions. I have tried both suggestions. The duplicate libraries seems not the issue as mentioned by Jan. I also have tried the updating the Arduino core for Nano 33 BLE sense by selecting version 1.3.1. Now, the previous error is gone, however, the compilation error still occurred:

Multiple libraries were found for “industrial-motion-classifier-nano33blesense_inference.h”
Used: C:\Users\Mohd Ridzuan\Documents\Arduino\libraries\ei-industrial-motion-classifier-nano33blesense-arduino-1.0.2
Not used: C:\Program Files (x86)\Arduino\libraries\ei-industrial-motion-classifier-nano33blesense-arduino-1.0.2
Using library ei-industrial-motion-classifier-nano33blesense-arduino-1.0.2 at version 1.0.2 in folder: C:\Users\Mohd Ridzuan\Documents\Arduino\libraries\ei-industrial-motion-classifier-nano33blesense-arduino-1.0.2
Using library Arduino_LSM9DS1 at version 1.1.0 in folder: C:\Users\Mohd Ridzuan\Documents\Arduino\libraries\Arduino_LSM9DS1
Using library Wire in folder: C:\Users\Mohd Ridzuan\AppData\Local\Arduino15\packages\arduino\hardware\mbed\1.3.1\libraries\Wire (legacy)
fork/exec C:\Users\Mohd Ridzuan\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\7-2017q4/bin/arm-none-eabi-g++.exe: The filename or extension is too long.
Error compiling for board Arduino Nano 33 BLE.

Thanks in advance for any suggestion.

Hi @Ridzuan,

This is related to a bug in the Arduino toolchain, you can apply the following patch to bypass it:

The alternative is to install the new Arduino Pro IDE.



Thank you everyone @dhruvsheth, @janjongboom and @aurel. After adding the patch, the compilation process is successful:

I do have something new to ask. Not sure whether I should create a new thread or continue here. It is related to the compilation time. Mine takes more than 1 hour. Yes, I wrote it correctly, hour. This is not normal, I know. Some says it is due to the antivirus software. As my antivirus software is a corporate version, I can not easily/simply temporary disable or uninstall unless I have the permission/password. Is there any other possibility for this forever like compilation time? Really appreciate for any insight on this matter.

1 hour is definitely too long. What kind of CPU/Ram do you have?
I would also suggest to try out the Arduino Pro IDE (Beta), the compile process is a bit different so hopefully it will be faster.


Hi @aurel,

My laptop is ran by Intel® Core™ i7-4550U CPU@ 2.10 GHz. The RAM is 8GB. Should be fine, I presume. Btw, just want to share a video of my movement-detection using Nano 33 BLE that was successfully trained (after long compilation time, phew):

I did a minor editing to the library example (I chose the non-continuous version). There are 5 different movements. In the video, I showed 3 of them. Each one will turn on a different LED color. Is there any different between non-continuous and continuous version of the library example?

I made an appointment with the IT office tomorrow. Hopefully, can disable the antivirus software and see its effect on the compilation time. If no avail, then I’ll try the new IDE as suggested. Thanks.

Also, a suggestion - You could try the Arduino Cloud IDE compiler, it’s quicker than this. Takes about 2mins tops.

1 Like

Hi @dhruvsheth,

Thanks for the suggestion. Yes, the web IDE just took about 1 minute to complete. Good alternative. Hope to see the same result using the desktop ide as well.

After uninstalling the antivirus software from my laptop, the Arduino IDE desktop can now consistently completing the compiling + uploading jobs in less than 2 minutes. Normally, the first-time compilation job takes about 5 minutes or so. The following subsequence jobs, due to the cache memory usage, just take 1-2 minutes or less for completion.