Error connecting to wss:// ENOTFOUND


Hi @lawga,

Which board are you trying to connect? Have you installed the Edge Impulse firmware on your board?


Hi @aurel,

I am using SiLabs Thunderboard Sense 2


And yes, I did install the Edge Impulse firmware on my board

@aurel Any hints on what might be going wrong?


I am looking into this now

@lawga I was able to connect my Silicon Labs Thunderboard 2 to one of my Edge Impulse projects via the Edge Impulse CLI version 1.13.0:

Can you please try the following steps:


@jenny I tried everything you mentioned, It did not work :frowning:
Help! :face_with_head_bandage:

Hi @lawga,

Can you try resolving the address from your PC and paste the output?



Do you actually have an internet connection? Is there a firewall blocking things? Can you access ?

@aurel I did try to resolve the address, seems like our company DNS server does not allow that

@janjongboom I can go to the provided link through a browser, I get the following :

Welcome to the Edge Impulse remote management API (mgmt-dd4f7478c-5767l)

I am behind a proxy, But I already did set http_proxy in cmd, I don’t know what else to try now :frowning:

Any crazy ideas? :slight_smile:

Hi @lawga,

Running out a bit of ideas but as we use secured websockets, can you set as well the https_proxy variable with your company’s proxy address used for HTTPS?


@aurel I already tried that with no luck! :frowning:

I guess am on my own since it’s a proxy problem?

@aurel @janjongboom @jenny

@lawga The only thing I can think of is setting the HTTPS_PROXY environment variable via:

1 Like

this one worked for me as I was able to connect to the repo and pick the project I want, I just don’t think that am able to look-up within the terminal. As our internal DNS server don’t recognize it.

I guess I have to work on my personal laptop with a no restriction connection

1 Like