Error Code 2? Deploying

I have no idea what the solution to this error would be. Any tips?

Creating job… OK (ID: 1352112)

Writing templates OK

Scheduling job in cluster…
Building firmware…
tookchain file /app/firmware-ai-vision/Platform/ECM3532/M3/ECM35xx_toolchain.cmake
LINKER_SCRIPT /app/firmware-ai-vision/Platform/ECM3532/M3/scripts/linker/flash_shm.ld.S
building csp from src
– Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
Doxygen not found
board : ai_vision
dspfw /app/firmware-ai-vision/Platform/ECM3532/M3/util/dsp_fw/dsp_fw_pdm.bin
Wrote: /app/firmware-ai-vision/Platform/ECM3532/M3/…/…/…/Applications/edge-impulse-ingestion/edge-impulse-ingestion.emProject
Inc path :: edge-impulse-ingestion
– Configuring done
– Generating done
– Build files have been written to: /app/firmware-ai-vision/Applications/edge-impulse-ingestion/build
[ 0%] Built target ldconf
[ 2%] Built target freertos
[ 4%] Built target rpc
[ 4%] Built target autoconf
[ 4%] Built target ses
[ 9%] Built target csp
[ 11%] Built target hal
[ 12%] Built target iodev
[ 14%] Built target eta_ai_bsp
Scanning dependencies of target edgeimpulse
[ 14%] Building CXX object CMakeFiles/edgeimpulse.dir/app/firmware-ai-vision/Thirdparty/edge_impulse/tflite-model/trained_model_compiled.cpp.o
Job started
[ 14%] Linking CXX static library /app/firmware-ai-vision/Platform/ECM3532/M3/pre_built/libedgeimpulse.a
[ 94%] Built target edgeimpulse
Scanning dependencies of target edge-impulse-ingestion.elf
[ 94%] Building CXX object CMakeFiles/edge-impulse-ingestion.elf.dir/src/ei_run_impulse.cpp.o
[ 94%] Linking CXX executable edge-impulse-ingestion.elf
/gcc-arm-none-eabi-8-2018-q4-major/bin/…/lib/gcc/arm-none-eabi/8.2.1/…/…/…/…/arm-none-eabi/bin/ld: edge-impulse-ingestion.elf section .text' will not fit in region FLASH’
/gcc-arm-none-eabi-8-2018-q4-major/bin/…/lib/gcc/arm-none-eabi/8.2.1/…/…/…/…/arm-none-eabi/bin/ld: section .dspBlock LMA [000000000106a000,000000000107f1f9] overlaps section .text LMA [0000000001006000,00000000010b3c5b]
/gcc-arm-none-eabi-8-2018-q4-major/bin/…/lib/gcc/arm-none-eabi/8.2.1/…/…/…/…/arm-none-eabi/bin/ld: region `FLASH’ overflowed by 324208 bytes
collect2: error: ld returned 1 exit status
CMakeFiles/edge-impulse-ingestion.elf.dir/build.make:451: recipe for target ‘edge-impulse-ingestion.elf’ failed
make[2]: *** [edge-impulse-ingestion.elf] Error 1
make[1]: *** [CMakeFiles/edge-impulse-ingestion.elf.dir/all] Error 2
CMakeFiles/Makefile2:1984: recipe for target ‘CMakeFiles/edge-impulse-ingestion.elf.dir/all’ failed
make: *** [all] Error 2
Makefile:103: recipe for target ‘all’ failed

Application exited with code 2 (Error)

Job failed (see above)

@E33933 It looks like your image recognition model may be too big for this target. Can you try using one of the MobileNet v1 0.2 models.

Just tried that. Sadly still the same error. Have absolutely no clue as to why.

My guess is that your model is still too big. In your impulse design, are you using a 96x96 image width and height? On the bottom right of the “Transfer Learning” page it will tell you how much flash is to be utilized for the model. I just exported again with no issues.

It says 223.9K for flash usage. Where can I apply this information? Sorry I am completely new to this whole thing, I am a new intern.

If that is your flash numbers then it should export just fine. Let me know your project id which is available near the bottom right of your Dashboard page and I can poke around and see what’s going on.

Project ID is: 49055

I am on a ETA Vision Board by the way.

I think it should be working now.

1 Like