Error at running edge-impulse on ThunderBoard 2

Hallo and thank you in advance for your help.

I’m trying to introduce to Edge Impulse using a ThunderBoard 2 kit. I have followed the steps for running the sample for the board (

I could install the CLI tools succesfully, and update the firmware as suggested in the tutorial. But when I run the edge-impulse-run-impulse command the following error pops:

`assertion "(*input)->params.scale == EI_CLASSIFIER_TFLITE_INPUT_SCALE" failed: file erboard-sense-2\edgeimpulse/edge-impulse-sdk/classifier/ei_run_classifier.h", line Tensor**, uint8_t**)`

I think it should be something related to the firmware version or so. May you provide some advice?

Thank you

Hi @christian.franco,

We have a fix and it should be live later this week. I’ll ping you when this happens.

Hi @christian.franco,

We’ve update with the fix. Please try again.

Thank you very much, I will give it a try.

Hallo @rjames, After a while I can finally test the code with the lastest github version( todays version : 29/11/2021) and I face the same error. Is it something to do with the ei_microphone.cpp file? I see like an error (even though it compiles) shown in the Simplicity studio environment.

Thank you in advance

Hi @christian.franco,

Still having this issue?

I just checked and it’s building and running fine. Are you running a different model than the one provided in

If so, can you email me your model-parameters and tflite-model folders at

Hallo @rjames, thank you for your answer. Well, after re-compiling worked succesfully. I dont know why. Thank you for your help !

1 Like