Edge impulse is not providing arduino accerlerometer continious code on build


I have actually been working on Arduino Nano RP2040 for 1 month. Since, Edge impulse doesn’'t specifically provide model library for Nano RP2040, I get the model libraries in Nano BLE and with some teaks I deploy them on Nano RP2040 which was working fine.

As, I said, I have been working on this for past 1 month. I am working on the models related to accelerometer data. Initially, whenever I got the model by edge impulse, it had nano_ble_accelerometer_continuous file. And with some tweaks it was working on Arduino RP2040. But today, when I was working on the new model, this new model library did,'t contain the nano_ble_accelerometer_continuous but only nano_ble_accelerometer.

I thought I had some problems in my trained data. Hence, I went to the model which I created in the start of month for which I got nano_ble_accelerometer_continuous file back before then. But when I run it now, I again got nano_ble_accelerometer for that model too.

KIndly let me know, whether I am going wrong anywhere or if there is any major update. I need to have a accelerometer_continous code. Kindly guide me. Thanks in Advance.

Hello @Jatin,

Indeed it was a bug on our side, thanks for reporting it.

It will be fixed soon.



Hello @louis ,

Thanks for replying. I am glad to know it’s not a major update and I will be able to get this code soon. Could you please tell me, how much time it may take to fix this bug? Thanks in Advance.

Jatin Kadge

A pull request has been created by @rjames so probably very soon.



Hi @Jatin,

The fix is live. Please re-deploy.

// Raul

1 Like

Hey @louis and @rjames,

Thanks for the reply. Thanks for fixing the bug. I do got the nano_ble33_accelerometer_continuous code. However, I am facing an issue in compiling it. Even though I am working with Arduino Nano RP2040, as a baby step, I just tried compiling the nano_ble33_accelerometer_continuous code without any changes.

  1. While compiling this unaltered code, I run into error as follows:
    nano_ble33_sense_accelerometer_continuous:193:2: error: #error “Invalid model for current sensor”
    #error “Invalid model for current sensor”
    exit status 1
    #error “Invalid model for current sensor”

  2. I then thought this might be because line #191 has EI_CLASSIFIER_SENSOR_ACCELEROMETER.
    Hence, I changed this to EI_CLASSIFIER_SENSOR_FUSION.
    On running this code, I ran into a new error as follows. The error was too big, thus, this is last few lines of error:
    C:\Users\user\Documents\Arduino\libraries\Welcome_Arduino_RP2040_once_again_inferencing\src/edge-impulse-sdk/classifier/ei_run_classifier.h:625:6: warning: ‘void {anonymous}::run_classifier_init(const ei_impulse_t*)’ defined but not used [-Wunused-function]
    void run_classifier_init(const ei_impulse_t *impulse)
    exit status 1
    ‘ei_classifier_smooth_t’ was not declared in this scope

Kindly help me out with this error. Thank you in advance.