Edge-impulse-daemon usb serial connection not working (windows)

Hi, I have problems again! I finally managed to install the edge-impulse-client and I am connected to an esp32 cam board which I flashed a modified edge impulse to. I hope its the right firmware (Its a no name amazon variety that looks like ai thinkers esp 32 cam, so I put in that in the definition)

However! My usb port (com8) seems to be busy and the client cant use it. I also tried using webUSB in chrome and got the same error that the port was busy or that the board might not be edge impulse supported.

Any ideas how I can get the edge-impulse-daemon to talk to my esp32 cam board? I unfortunately have no other type of boards to test with, other than a few microbits, but theyre not supported officially right?

Including pics of error, and of my (same sort, borrowed pic) esp32 cam board.

Thanks for any help

Now after setting the baudrate to 115200-8-1-N in device manager I can get it to this stage:

Does this mean my firmware is not correctly flashed?

edit: I downloaded the latest firmware, but substituted the firmware_esp32.bin file with the one I made for my board (ei_firmware_esp32.bin ----> rename to firmware_esp32.bin) and ran the included .bat file to flash it.

Seemed to work, but it still doesnt recognize the board. So another indication I might have messed up the firmware building?


Nevermind. It seems everytime I ask after really trying everything to no avail, it always starts working, haha :smiley:

I cloned the firmware again, redid all the steps to build and flash, and now it seems to be working better!

However…the serial connection seems unstable. I got maybe ten minutes in the edge impulse studio with the board connected, then it disconnected and is timing out again. Very wierd. Will try another cable, those things break all the time.

I could only get it to work for 10 minutes and now its back to “[SER] Serial is connected, trying to read config…
[SER] Failed to get info off device Timeout when waiting for > (timeout: 5000) onConnected”. Very wierd.


Further investigating the error, I can connect again if i reflash the esp32 with the same firmware, then it seems to be working again. Not sure how long, but I will let you know.

edit: I get this error when sampling from the camera:

[WS ] Incoming sampling request {
path: ‘/api/training/data’,
label: ‘test2’,
length: 60000,
interval: 0,
hmacKey: ‘ccaa18ba2fa31adc6cfe48d81f0fcbcf’,
sensor: ‘Camera (96x96)’
[SER] Stopping snapshot stream mode…
[SER] Stopped snapshot stream mode
[SER] Taking snapshot…
[SER] Reading 8% complete…
[SER] Reading 8% complete…
[WS ] Failed to sample data Error: Invalid length for snapshot, expected 9216 or 27648 values, but got 23
at SerialDevice.sampleRequest (C:\Users\Jonas\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\cli\daemon.js:284:23)
at async WebSocket. (C:\Users\Jonas\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\shared\daemon\remote-mgmt-service.js:173:21)

Hello @Instant_exit ,

I suspect you’re having an issue with either your uart to usb converter (the lower part of the AI-Thinker where there is the usb port) or the usb cable. The UART connection seems unstable from what you shared.
Could you try with another usb cable to check if it works better?



I will try another cable! And another esp32cam they came in pairs.

But I noticed it seems to be working fine as long as i dont leave the data collection window. If i go to another part of the site and then back again, it stops working. Dont know if the cable can cause that, or It could be a coincidence, I will have to do more testing.