Edge-impulse-daemon raise the error: Error: Cannot find module '../sdk/studio/api'

Question/Issue:
I’m following this guide: Renesas EK-RA8D1 | Edge Impulse Documentation.
When I launch the daemon, the following error arise: Error: Cannot find module ‘…/sdk/studio/api’

Project ID:
Not yet created

Context/Use case:
Following this guide: Renesas EK-RA8D1 | Edge Impulse Documentation

Summary:
Seems like the sdk is missing. I’m using node js, as reported in the guide. I followed all steps untill the edge-impulse-daemon which causes the problem.

Reproducibility:

  • [X] Always
  • [ ] Sometimes
  • [ ] Rarely

Environment:

  • Platform: Renesas EK-RA8D1
  • Build Environment Details: Powershell
  • OS Version: Windows 11

Logs/Attachments:

Same error here. I get this error after installing edge-impulse-cli on two PCs yesterday and today. Both PCs are 64-bit Windows 11, one with Visual Studio 2019 Community, the other with VS 2022 Community. Both has Node.js version 20.15.0.


This solution from here worked for me:
npm install -g edge-impulse-cli@1.26.0 --force

2 Likes