Edge-impulse-daemon: command not found

Super weird… Can you try:

$ sudo chown -R 1000:1000 /home/ic6/.npm-packages
$ sudo npm link
$ edge-impulse-daemon

Or if this still does not work:

$ cd ~/edge-impulse-cli/package
$ ln -s $PWD/build/serial-daemon/cli/daemon.js /usr/local/bin/edge-impulse-daemon

(Last one might require sudo)

Hi @janjongboom,

Apologies for resurrecting this old thread. I am trying to run ‘edge-impulse-daemon’ with Arduino nano ble-33 sense as a part of the Coursera course and see a similar error.

Could you please suggest if it was concluded when reported last time?

balaji@ubuntu-workstation:~/Arduino/bin$ edge-impulse-daemon
    throw e;

Error: The module '/home/balaji/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/build/Release/bindings.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 64. This version of Node.js requires
NODE_MODULE_VERSION 83. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).
at Object.Module._extensions..node (internal/modules/cjs/loader.js:1122:18)
at Module.load (internal/modules/cjs/loader.js:928:32)
at Function.Module._load (internal/modules/cjs/loader.js:769:14)
at Module.require (internal/modules/cjs/loader.js:952:19)
at require (internal/modules/cjs/helpers.js:88:18)
at bindings (/home/balaji/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/bindings/bindings.js:112:48)
at Object.<anonymous> (/home/balaji/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/lib/linux.js:2:36)
at Module._compile (internal/modules/cjs/loader.js:1063:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
at Module.load (internal/modules/cjs/loader.js:928:32)


npm uninstall edge-impulse-cli -g
npm install edge-impulse-cli@latest -g

Performing an uninstall and re-install worked for me, thanks!

1 Like

Hey, Ubuntu 20.04 user here, I fumbled a bit with these issues as well, just so it helps anyone that cannot run the commands although install works fine, for me what worked was to export the path :

export PATH=$PATH:/home/$USER/.npm-global/bin

Afterward, the commands were available anywhere else.


“edge-impulse-daemon: command not found”
i tried every step but what ever i do same error !!!

Hello @techie ,

Which OS do you use?
When nothing of the above works, I have seen user reporting that restarting their computer solved the issue… Urgent edge-impulse-daemon: COMMAND NOT FOUND - #12 by Haythem.listic

Let me know if that fixes it



FYI, this is already done in the installation step at https://docs.edgeimpulse.com/docs/edge-impulse-cli/cli-installation#installation-linux-ubuntu-macos-and-raspbian-os:

echo 'export PATH=~/.npm-global/bin:$PATH' >> ~/.profile

What’s missing is the command:

source ~/.profile

Which will actually apply the changes made in the previous command, and then edge-impulse-daemon works.

@louis may I suggest this command is added to the documentation of Edge Impulse CLI, since many (like me) will forget it’s needed?