Urgent edge-impulse-daemon: COMMAND NOT FOUND

Hi everyone, this is my first time posting in a forum.
So after installing edge-impulse-clli doing : edge-impulse-daemon
i do not know what to do, please help this is for my project urgent

Hello @Haythem.listic ,

Can you share the logs output of the edge-impulse-cli installation please?
Which OS do you use?
Can you make sure you’ve installed the additional tools when installing NodeJS? Usually it is the most common issue.

Also, see the Installation - Edge Impulse Documentation 's troubleshooting section to any of the hints can solve your issue.



I am using LINUX.
here is the output of the edge-impulse-cli installation:
npm WARN deprecated @zeit/dockerignore@0.0.5: “@zeit/dockerignore” is no longer maintained
npm WARN deprecated request-promise@4.2.4: request-promise has been deprecated because it extends the now deprecated request package, seehttps://github.com/request/request/issues/3142
npm WARN deprecated request@2.88.0: request has been deprecated, seehttps://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. Seehttps://v8.dev/blog/math-random for details.
npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (ReDos Vulnerability Regression Visibility Notice · Issue #797 · debug-js/debug · GitHub)
/home/listic/.npm-global/bin/edge-impulse-blocks → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/blocks.js
/home/listic/.npm-global/bin/edge-impulse-uploader → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/uploader.js
/home/listic/.npm-global/bin/edge-impulse-daemon → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/daemon.js
/home/listic/.npm-global/bin/edge-impulse-data-forwarder → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/data-forwarder.js
/home/listic/.npm-global/bin/edge-impulse-run-impulse → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/run-impulse.js
/home/listic/.npm-global/bin/eta-flash-tool → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/eta-flash-tool/flashtool.js
/home/listic/.npm-global/bin/himax-flash-tool → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/himax-flash-tool/flashtool.js
/home/listic/.npm-global/bin/edge-impulse-framebuffer2jpg → /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/framebuffer-to-jpg.js

@serialport/bindings@8.0.8 install /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings
prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild

prebuild-install WARN install No prebuilt binaries found (target=14.19.1 runtime=node arch=x64 libc= platform=linux)
make: Entering directory ‘/home/listic/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/build’
CXX(target) Release/obj.target/bindings/src/serialport.o
CXX(target) Release/obj.target/bindings/src/serialport_unix.o
…/src/serialport_unix.cpp: In function ‘int setup(int, OpenBaton*)’:
…/src/serialport_unix.cpp:166:5: warning: ‘%s’ directive output may be truncated writing up to 1023 bytes into a region of size 1005 [-Wformat-truncation=]
int setup(int fd, OpenBaton *data) {
In file included from /usr/include/stdio.h:862:0,
from …/src/serialport.h:3,
from …/src/serialport_unix.cpp:2:
/usr/include/x86_64-linux-gnu/bits/stdio2.h:65:44: note: ‘__builtin___snprintf_chk’ output 20 or more bytes (assuming 1043) into a destination of size 1024
__bos (__s), __fmt, __va_arg_pack ());
…/src/serialport_unix.cpp: In function ‘void EIO_Open(uv_work_t*)’:
…/src/serialport_unix.cpp:79:6: warning: ‘%s’ directive output may be truncated writing up to 1023 bytes into a region of size 1003 [-Wformat-truncation=]
void EIO_Open(uv_work_t* req) {
In file included from /usr/include/stdio.h:862:0,
from …/src/serialport.h:3,
from …/src/serialport_unix.cpp:2:
/usr/include/x86_64-linux-gnu/bits/stdio2.h:65:44: note: ‘__builtin___snprintf_chk’ output 22 or more bytes (assuming 1045) into a destination of size 1024
__bos (__s), __fmt, __va_arg_pack ());
CXX(target) Release/obj.target/bindings/src/poller.o
CXX(target) Release/obj.target/bindings/src/serialport_linux.o
SOLINK_MODULE(target) Release/obj.target/bindings.node
COPY Release/bindings.node
make: Leaving directory ‘/home/listic/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/build’

serialport@8.0.5 postinstall /home/listic/.npm-global/lib/node_modules/edge-impulse-cli/node_modules/serialport
node thank-you.js

Thank you for using serialport!
If you rely on this package, please consider supporting our open collective:

Contribute to SerialPort - Open Collective

npm WARN tsargs@1.4.1 requires a peer of typescript@^3.1.6 but none is installed. You must install peer dependencies yourself.

  • edge-impulse-cli@1.14.8
    added 388 packages from 266 contributors in 16.666s
  • edge-impulse-cli@1.14.8
    added 388 packages from 266 contributors in 16.666s

It seems that it has been installed properly

Can you try to quit your terminal and open it again?

Yes i did that.
its still command not found.
this is very weird.
maybe its a path problem. i followed everything right though

What’s the output of the following command?

npm config get prefix

its: /home/listic/.npm-global

in which file should i do edge-impulse-daemon ?
right now i am in home/listic

It is accessible in any folder as you installed it globally…

Then what is the problem in my case ? what should i do ? I really need this to work

I usually don’t like advising this method but have you tried to restart you laptop?
Some users fixed this issue just by restarting their computer…

1 Like

Restaring my laptop has actually solved the problem :slight_smile:
Thanks a lot Louis

1 Like