Edge-impulse-daemon: command not found on Ubuntu 22.04.1 LTS

I am working on Ubuntu 22.04.1 LTS. I followed the instruction set but when I enter edge-impulse-daemon on the terminal, I faced to command not found error. Do you have any solution or suggestion?

Hello @umutt,

Did you check the troubleshooting section for the CLI installation: Installation - Edge Impulse Documentation

Have you had any errors during the installation?

Regards,

Louis

Hi @louis,
Yes, I checked the troubleshooting section and could not find any solution to my problem and no, I did not receive any error during installation.

Hi @umutt,

Which Node version do you have?
I suspect a npm path issue here.
Could you try to uninstall edge-impulse-cli and install it again please?

If it still does not work, other users reported that rebooting your machine may help :confused:

Regards,

Louis

Hi Louis,

My npm version is 8.15.0. I had tried to uninstall and reinstall it. However, there is no change. How can I check npm path is true?

Regards,
Umut

Hi @umutt

You can do locate edge-impulse-daemon if this returns positive then you need to add the path to the javascript binaries to your path.

Usually, they are installed under /home/username/.npm-global/bin so you need to add this to your path in your export PATH

I run locate command and you can see the result on the image. How can I export PATH?

As mentioned above, you must add the path in your home directory to your PATH variable.
Have a look here:

I solved my problem. I wrote the below command then it run.

export PATH="/home/eda/.npm-global/bin:/usr/local/share/npm/bin:/usr/local/bin:/usr/local/sbin:~/bin:$PATH"

Thanks for helping.

1 Like