Edge Impulse CLI Upload problem

When trying to upload elephant .png files from a Windows 10 directory full of elephant photos using this command: edge-impulse-uploader --category split --label elephant *.png I get this error:

Failed to upload files ENOENT: no such file or directory, stat ‘.png’
Error: ENOENT: no such file or directory, stat '
at Object.statSync (node:fs:1690:3)
at C:\Users\erbjo\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\cli\uploader.js:338:59 {
errno: -4058,
syscall: ‘stat’,
code: ‘ENOENT’,
path: ‘*.png’

If I use the exact name of the file: edge-impulse-uploader --category split --label elephant 2019-09-10_01-15-41.427506.png

It works, but obviously I only get that one file.

Project ID 269089

Trying to follow tutorial on hackers.io : Image Classifier with EDEG IMPULSE - Hackster.io

Hi @johnerb,

I just tried, and it worked for me using *.png (using the dataset in that Hackster project). Just to verify, are you calling edge-impulse-uploader --category split --label elephant *.png from the directory with the images? For example, make sure you cd human-wildlife-conflict-master/Elephant/Object/single_elephant before calling the uploader with *.png as the argument.

Shawn, thanks.
I used git clone to download the dataset and it had only human-wildlife-conflict without the ‘master’ in the path. I downloaded the dataset again, this time using the zip file and now I have ‘human-wildlife-conflict-master’ path. Unfortunately that didn’t make a difference.

Also I am running on Windows 11 and using a PowerShell terminal so all of my slashes are in a different direction.

I can ingest all of the files into my project from the Edge Impulse web interface (add existing data) but they don’t come in with labels and I don’t really want to label 7000+ images one at a time. Is it possible I need a properly configured bounding_boxes.labels file in the correct directory? I attached a screen print of the error.

Hi @johnerb,

Hmm…that might be a PowerShell issue. Could you try with WSL2?

I tried it with WSL2 and it worked fine! As I uploaded more and more data I started to get a lot of “An item with this hash already exists” errors. Found another post in the forum that recommended using the --allow-duplicates flag. Did that and was able to upload all of the data I needed.

I may try using a normal Command Prompt window or Windows 11 Terminal window if I can do so without PowerShell getting in the way, but will probably just continue with WSL2 or move this activity to a full blown Ubuntu machine.

Thanks for your help.

1 Like