Edge Impulse Cli Install error on Jetson Nano

I have Ubuntu 20.04 installed on a Jetson Nano and I’m following the instructions here.

However, when I run this command:

wget -q -O - https://cdn.edgeimpulse.com/firmware/linux/jetson.sh | bash

It fails with this error:

E: Unable to locate package glib2.0-dev
E: Couldn't find any package by glob 'glib2.0-dev'

I then thought maybe that package wasn’t installed so I ran this with output:

sudo apt-get install glib2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libglib2.0-dev-bin' for regex 'glib2.0-dev'
Note, selecting 'libglib2.0-dev' for regex 'glib2.0-dev'
libglib2.0-dev is already the newest version (2.64.6-1~ubuntu20.04.4).
libglib2.0-dev-bin is already the newest version (2.64.6-1~ubuntu20.04.4).
The following package was automatically installed and is no longer required:
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I did remove the other package I mentioned. Anyone have any ideas? Thanks!

I got past that hick-up by downloading the shell script and changing this:

sudo apt install -y gcc g++ make build-essential pkg-config glib2.0-dev libexpat1-dev sox v4l-utils libjpeg-turbo8-dev

to this:

sudo apt install -y gcc g++ make build-essential pkg-config libglib2.0-dev libexpat1-dev sox v4l-utils libjpeg-turbo8-dev

I have no idea if this was a bad idea or not.

1 Like

Hi @iangillespie ,

Just to confirm your CLI is now installed correctly on your Jetson Nano?


Yes, I did get it installed correctly. Thanks for following up.

1 Like