Do you want live notifications when people reply to your posts? Enable Notifications Issues with installing edge-impulse-cli on MacOS

Hi, I have a problem with the installation of the cli on a Macbook Pro 2023. The cli (and the other packages are installed) but when running edge-impulse-linux-runner the “command is not found”.

Uninstalled and reinstalled. Tried all the solutions in other questions.

Any suggestions?

  • Seems like a PATH issue.

    • Either add the folder where edge-impulse-linux-runner resides or CD to that folder and run the Runner.
  • The syntax for the Runner needs an EIM (Edge Impulse Model) file that you download from the EI Studio Dashboard.

    • edge-impulse-linux-runner --download modelfile.eim

Thanks! Solved the issue. But now I am encountering a problem with flashing a new binary. I changed a model, downloaded the build and flashed it to the board. But get this error:

panic: runtime error: invalid memory address or nil pointer dereference

[signal SIGSEGV: segmentation violation code=0x2 addr=0x68 pc=0x10358f924]

I also downloaded the new eim-file to the same directory as the previous one.

Searched everywhere but can not find a solution.

Suggestions are much appreciated.