Dge-impulse-daemon Error


I am using the OpenMV4 H7 Plus, I have an error while I install the Edge impulse.
Below is the message in the terminal, please advise.

Edge Impulse serial daemon v1.8.4
Websocket: wss://remote-mgmt.edgeimpulse.com
API: https://studio.edgeimpulse.com/v1
Ingestion: https://ingestion.edgeimpulse.com

[SER] Connecting to COM4
[SER] Serial is connected, trying to read config…
[SER] Retrieved configuration
[SER] Device is running AT command version 1.0.0
Configuring API key in device…[WS ] Failed to set upload settings: Traceback (most recent call last):
File “”, line 1, in
SyntaxError: can’t assign to expression
[SER] Cannot connect to remote management API using daemon, failed to read apiKey, deviceId or deviceType from device. Restarting your development board might help. Retrying in 5 seconds…[/color]

Hi @myron, you don’t use the Edge Impulse Daemon for the OpenMV Cam but rather the OpenMV IDE.

See https://docs.edgeimpulse.com/docs/image-classification-openmv

The OpenMV ID pop out an error window when I use the OPENMV IDE,
“Error creating SSL context()”

Hi @myron, I saw you also posted something on the OpenMV forum. I’ve pinged Kwabena from OpenMV, perhaps he has an idea.

In the meantime you can use the Edge Impulse uploader. Open a command prompt and run:

$ edge-impulse-uploader --format-openmv c:\path\to\your\dataset

(replace c:\path\to\your\dataset with the location of your OpenMV dataset)

When I tried to upload images to Edge impulse with OpenMV IDE 2.6.5, I tried both API key option and login option, it gives me Error creating SSL context () error, even if I run OpenMV IDE in Administration mode. It only worked with edge-impulse-uploader after installing CLI.

1 Like