Deploying audio classification model on computer or mobile phone not working?

i have succesfully created a audio classification model by following this tutorial: Build Your Own ML-Powered Keyword Spotting Model in 30KB RAM - YouTube
. Now when i go to deployment > run impulse on computer > click build. A new tab opens > i give acces to microphone > its starts listening for 0.5 seconds and after that an error pops up:
Failed to load
Classification failed (err code: -5)

In the console on the browser i get the following:
ERR: Failed to run DSP process (-1013)

Now when i switch to data collection mode, it works just fine. But the live classification mode doesen’t work. The same error occurs when i run impulse on mobile phone and also on raspberry pi 4 with the edge-impulse-linux-runner command.

project id: 198363

Hello @ziekejuan344,

Can you tell me which DSP block you are using?

The error details can be found here.

If you’re using MFCC, try using MFE instead is you’re using audio. In the meantime, our core engineering team will have a look.

Let me know if that solve your issue, other people had the same issue.



It did not work with MFCC. I changed it to MFE and it works now.

1 Like