Deploy model to C++ Makefile error

Hello, makefiles have always been the bane of my existence. I just can’t seem to figure them out. I recently deployed my object detection model to the C++ library to run on a Kria KV260.

I’m trying to compile my code using the Makefile in the tutorial, but get the following error:

g++: fatal error: cannot specify ‘-o’ with ‘-c’, ‘-S’ or ‘-E’ with multiple files

I searched the interwebz but couldn’t find anything useful on how to resolve. I don’t think I have references to duplicate files. Each time I run make -j 4 it seems to error out on a different file.

Any Makefile gurus out there? Any idea what could be causing it? Thanks!

Hi @jlutzwpi,

I suppose you’re running a Linux OS on this target. I’d suggest following this link:

You can specify the AARCH64 target while building, hopefully this will fix your issue.

There’s also a tutorial on the Kria here, but it is using the tflite model only and not the C++ library.



That worked, thank you! It takes about 19s for inference, but it is working at least! Thank you for the insight.

I did see the other tutorial. There are a couple gaps in it that I’ve mentioned in a separate thread, and I don’t think there is an equivalent model in the Xilinx Model Zoo for the MobileNet V2 SSD model that Edge Impulse uses for object detection.

Thanks again!

1 Like