Data forwarder error - incompatible architecture 'arm64e'


I’m trying to forward data but getting “ERR_DLOPEN_FAILED”

I’m using - XIAO nRF52840 Sense and serial data stream.

Please help?

Error: dlopen(/usr/local/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/build/Release/bindings.node, 0x0001): tried: ‘/usr/local/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/build/Release/bindings.node’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/local/lib/bindings.node’ (no such file), ‘/usr/lib/bindings.node’ (no such file)
at Module._extensions…node (node:internal/modules/cjs/loader:1340:18)
at Module.load (node:internal/modules/cjs/loader:1119:32)
at Module._load (node:internal/modules/cjs/loader:960:12)
at Module.require (node:internal/modules/cjs/loader:1143:19)
at require (node:internal/modules/cjs/helpers:121:18)
at bindings (/usr/local/lib/node_modules/edge-impulse-cli/node_modules/bindings/bindings.js:112:48)
at Object. (/usr/local/lib/node_modules/edge-impulse-cli/node_modules/@serialport/bindings/lib/darwin.js:2:36)
at Module._compile (node:internal/modules/cjs/loader:1256:14)
at Module._extensions…js (node:internal/modules/cjs/loader:1310:10)
at Module.load (node:internal/modules/cjs/loader:1119:32) {

Hello friend, curiosity did you use Arduino IDE to load? I remember testing a few things on Seeed XIAO sense, but I can have a look later.
I remember seeing that link.

I did follow the wiki but it still doesn’t connect to the device. The prompt says:

Edge Impulse serial daemon v1.21.1
[SER] Connecting to /dev/tty.usbmodem1101
[SER] Failed to connect to /dev/tty.usbmodem1101 retrying in 5 seconds Error: Resource busy, cannot open /dev/tty.usbmodem1101

I looked around and some suggested updating the firmware. I have yet to find the latest version. The current version is this:

UF2 Bootloader 0.6.2-12-g459adc9-dirty lib/nrfx (v2.0.0) lib/tinyusb (0.10.1-293-gaf8e5a90) lib/uf2 (remotes/origin/configupdate-9-gadbb8c7)
Model: Seeed XIAO nRF52840
Board-ID: Seeed_XIAO_nRF52840_Sense
Date: Nov 30 2021
SoftDevice: S140 7.3.0

Would a new firmware will help?

Is there Edge impulse connectivity-bridge.hex available for Sense?