Data doesn't get uploaded from edge impulse daemon

I flashed the Windows Batch file and then ran the edge impulse daemon command for my Arduino Nano BLE 33 Sense. It worked well and said that it was connected to COM8. I went to my project and thought collecting some accelerometer data. The length was 10000ms or 10secs and the frequency was 62.5Hz. It said that the sampling started and I moved the Arduino to make some data. But after the sampling was over the data didn’t get uploaded and no errors were there. I waited for sometime but still nothing was there. If anyone has any fix then please help me.
Here is the output :

Blockquote Microsoft Windows [Version 10.0.19043.1052]
© Microsoft Corporation. All rights reserved.
Edge Impulse serial daemon v1.13.12
Websocket: wss://
[SER] Connecting to COM8
[SER] Serial is connected, trying to read config…
[SER] Retrieved configuration
[SER] Device is running AT command version 1.3.0
? To which project do you want to connect this device? Darsheel / NanoBLE33Test’
[SER] Device is not connected to remote management API, will use daemon
[WS ] Connecting to wss://
[WS ] Connected to wss://
[WS ] Device “Arduino BLE 33 AI/ML” is now connected to project “NanoBLE33Test’”
[WS ] Go to to build your machine learning model!
[WS ] Incoming sampling request {
path: ‘/api/training/data’,
label: ‘UP-DOWN’,
length: 10000,
interval: 16,
hmacKey: ‘8911b2838451f88442258413de8df78f’,
sensor: ‘Built-in accelerometer’
[SER] Configured upload settings
[SER] Sampling started

I have the exact same issue.
I can upload the microphone data but nothing happens while using the accelerometer.
I’m using Chrome browser and Windows 10.
Looking forward for an answer.

Try reducing the recording length, and check whether it works?
(Try at diff length 2 sec 4 sec …)
And try recording again with another USB cable.

I tried changing frequency, duration and even tried WebUSB.
Nothing works.

Hello @Darsheeltripathy,

As @Sanyam suggested, could you try with a different USB cable too please?

Hi @Darsheeltripathy,

I’ve found a workaround. Instead of using edge-impulse-daemon to upload the accelerometer data, I used the edge-impulse-forwarder.
For that I upload a code to the MCU (in my case I used Arduino IDE) that basically keeps printing the data of the sensors in an interval of time. After that, I called edge impulse forwarder and it worked.
If you need help with this code, let me know.

1 Like

Good that you found a work around!
If any other users have an issue, indeed you can check this code from our documentation:

If you changed anything or have a different code @MarceloMTM, feel free to copy paste here a link as it may interest other people.

Have a great day,


Thanks to everyone for their valuable suggestions.
Its working now and my project is pretty much ready!!
Thanks guys for resolving this issue.


@Darsheeltripathy Did you solve this via the work around or get to the bottom of the issue? I’m experiencing the exact same problem on Mac.

Just to add: the workaround using the data forwarder rather than the daemon works for me also.

1 Like