Data acquisition using WebUSB

I was reading the Help Documentation and see that it is possible to collect data using the WebUSB function as explained in a blog

.I am looking to collect data from my Nano 33 BLE. I have Google Chrome installed on my LapTop (Version 116.0.5845.96) and have it open.

Regardless of what I do in Edge Impulse Studio, the button “Connect using WebUSB” does not appear in the data acquisition page.

Is there something else that needs to be done?

That is now under the very small USB icon:

The USB icon does not show up on my Collect Data, even after I have tried some different configurations (opened Google Chrome, Changed target device, connected Nano to USB)


  • This seems like a bug to me.
    • Often times the Studio will think for the user and hide content and controls based on the Project’s current configuration.
  • Try creating a brand new project.

Hello @kevinjpower,

Could you try with a different browser?
Usually it works well with chrome but you might have an ad blocker running that is changing the interface.



I only ever use Mozilla Firefox as my browser. Which is not a supported browser for WebUSB.

So I swallowed my pride, installed Google Chrome and logged into my Edge Impulse account.
In this environment, the WebUSB icon showed up. I tested it and no problem, everything worked.

So problem solved - use a supported browser.

Thanks for the help

1 Like

@kevinjpower I verified the USB icon is not there under FireFox as you noticed.

For the id on the Connect using WebUSB icon FireFox says don’t display it for some unknown reason:

id="connect-webserial" style="display: none"

Under Chrome it is:

id="connect-webserial" style=""

So maybe this is a bug when using FireFox or the Studio is hiding elements that are not yet ready to be displayed or is hiding elements that are only needed in certain circumstances. I have no idea what those circumstances might be, tho.

Don’t think this is a bug. Because Firefox is not a supported browser for the WebUSB function, it is not unreasonable to hide the icon when using Firefox.

Of course it would be nice if the icon was there and when the user tried using it, a message appeared “unsupported browser” or similar.

1 Like

An ABSOLUTELY reasonable request/idea.