Custom Speech Commands Dataset

@ShawnHymel I tried your Custom Speech Commands Dataset
and Generate Features errored on 329 of the 530 files, aka they could not be ingested with an error like:

WARN: failed to process 129170/training/ Error

  • Flagged all archie (19 total files)
  • Flagged all fenrir (16 total files)
  • Flagged all goodnight (15 total files)
  • Flagged all hadouken (109 total files)
  • Flagged all hey_archie (15 total files)
  • Flagged all hey_fenrir (13 total files)
  • Flagged all how_are_you (22 total files)
  • Flagged 20 joke (46 total files)
  • Flagged 100 dracarys (100 total files)
  • Flagged none trick_or_treat (66 total files)

The Generate Features job finally failed.

Why are so many files being flagged as not ingestible?

Project ID: 29170

Hi @MMarcial,

Where did you see this error? Was it on the Studio or were you running another script to upload?

I just tried the curation and upload process using this notebook, and it worked OK for me.

Also, 29170 does not seem to be your project–is that the correct project ID on Edge Impulse?

The injection error I saw 2 days ago was during Generate Features not during Upload.

I just ran Generate Features today and it worked as expected.

(I fat fingered the Project ID. It’s 129170 not 29170.)

1 Like

Hmmm…that’s weird. Maybe it happened during an update (or better, a glitch in the Matrix :). Let me know if it happens again!