CSV File: Failed to Load Sample

Hi Edge Impulse Team,

I successfully uploaded a csv file. The csv data looks like this.

In the Edge Impulse Data Acquisition tab, the csv file was visualized.

However, when I’m trying to load the csv data for testing, Edge Impulse return a prompt

Error while loading features: Unable to allocate array with shape (312512500500021,) and data type int64

What is the problem in this case, is there something I need to do in the csv file?

This is not a somewhat ‘correct answer’ - it is more of a workaround.
I had the same issue, the thing that solved the problem for me was setting a constant timestamp difference (e.x 26, so the timestamp would go as follows: 0, 26, 52, …).
Luckily for me, the sensor readings were almost always coming with the same timestamp difference - so it did not affect my data. I hope you will find the ‘correct’ solution to your problem or use this workaround.


Thank you for your response, I tried your suggestion, unfortunately it did not work for me.

Hello @TronixLabPH,

Could you share your csv dataset so I can have a deeper look please?
As @Orzech said, we need to have a constant frequency and also I think we only take integers for the timestamp so maybe if you have something like 0, 15.5, 31, … we would only take 0, 15, 31, … so it won’t be constant to our ingestion api in this case. But maybe there is something else?



1 Like

Thank you Louis for your response,

I uploaded again the sample csv file named “AnomalySampleCSV” on my project. The said file look like this.

The sampling rate of the project is 52Hz, so I assumed the time interval is every 19ms. I’m trying to load the file for anomaly and classification testing, yet, it prompt the same error. See the image below.

Hello @TronixLabPH

Ok, I had a quick look at your project and it appears the frequency of all your data is 52Hz but the one you are trying to test (AnomalySampleCSV) is 52.63… Hz thus there is an inconsistency in the frequency:

You can see this screen under the Test data tab in the Data Acquisition view by clicking on the “expand” icon on the upper-right corner of your data sample view.



1 Like

Hi Louis,

Once again, thank you for your response; I’ve figured out what has to be done. After a little adjustment on data, I’ll return to this thread later.

Thank you so much Louis. I adjust the period to 20ms, resulting in 50Hz, the project sampling rate is 52Hz, still this works fine now :grinning:. This thread is solved. :handshake: :slightly_smiling_face:

1 Like