Creating .elm file for Jetxon Xavier NX

I am trying to create the elm file for the project given at the below link:

I have placed the ei-pharma-pills-defects-object-detection-tensorflow-lite-float32-model.lite inside the same folder where I have to invoke the command

unfortunately, it falls to error as below:

arun@arun:~/vips-8.12.1/example-standalone-inferencing-linux$ APP_EIM=1 TARGET_JETSON_NANO=1 make -j
make: *** No rule to make target 'edge-impulse-sdk/tensorflow/lite/c/common.c', needed by 'edge-impulse-sdk/tensorflow/lite/c/common.o'.  Stop.
arun@arun:~/vips-8.12.1/example-standalone-inferencing-linux$ ** No rule to make target 'edge-impulse-sdk/t

My development environment is as follows:

arun@arun:~/vips-8.12.1/example-standalone-inferencing-linux$ jetson_release
Software part of jetson-stats 4.2.1 - (c) 2023, Raffaello Bonghi
Model: NVIDIA Jetson Xavier NX Developer Kit - Jetpack 5.0.2 GA [L4T 35.1.0]
NV Power Mode[3]: MODE_10W_2CORE
Serial Number: [XXX Show with: jetson_release -s XXX]
 - P-Number: p3668-0001
 - Module: NVIDIA Jetson Xavier NX
 - Distribution: Ubuntu 20.04 focal
 - Release: 5.10.104-tegra
 - Version: 4.2.1
 - Service: Active
 - CUDA: 11.4.239
 - cuDNN:
 - TensorRT:
 - VPI: 2.1.6
 - Vulkan: 1.3.203
 - OpenCV: 4.5.2

Where as I am able to run the demo on the Browser. I also installed the right TensorFlow version on my device.

Here is the way I installed:
sudo pip3 install --extra-index-url tensorflow=2.9.1+nv22.06

Project ID:

Context/Use case:

Okay, so I see the link goes to one of our expert community projects. Officially we only offer deployment on Jetson Nano.
I will try contacting the person who wrote the tutorial to see if they can have a look.
Meanwhile, here are some things you can try:

  1. The error you are seeing is very generic - perhaps you have some leftover files from last build? try running make clean
  2. You have TensorRT 8.4, which means you’re running quite recent JetPack… Our TensorRT deployment officially supports only Jetson Nano, which only has older 8.0.1 TensorRT support - this is NVIDIA’s limitation. Also in tutorial, which you are trying to run it is mentioned it is based on JetPack 4.6.2. Can you make sure your Xavier NX has JetPack 4.6.2 installed and not later version?
1 Like

Thank you for your reply and helping further on this topic.
I am looking for the deployment pipleine for Jetson Xavier NX. I can repeat the experiment with JP4.6.2 for sure and update here.
I tried to execute the project, it ran also in Browser, seems online inference mode. I wanted to execute this on local device.

Kind Regards

Oh, and do you have edge impulse SDK folder present in your project folder? It is part of the deployment.
Not having it might cause the error you are seeing, since indeed edge-impulse-sdk/tensorflow/lite/c/common.c would be missing :slight_smile:

No, I tried to find it on the Impulse references, but unfortunately there is no link to download the SDK components, could you please share the download link for the Impulse SDK?
I followed the tutorial and there its not mentioned I guess.


I am 100% sure that edge-impulse-sdk is present in TensorRT deployments

Make sure you are following the steps outlined in Pharmaceutical Pill Quality Control and Defect Detection - Expert Projects correctly. It does say there
Now unzip the downloaded model bundle from the Deployment step into this folder.