Could not find a valid build artifact [SOLVED]

I’m following the device connection instructions for arduino nano ble sense. When I get to the step to flash the impulse edge firmware onto the device I’m getting this message:

Has anyone else encountered this, if so please share any known workaround.

Just to confirm I have:

  1. installed node.js (version listed above)
  2. have the arduino CLI in my user folder
  3. have installed Edge Impulse CLI via command line
  4. have the flash_windows file in the same folder as arduino CLI



Sorry, I have solved this. My mistake is that when I moved the “flash_windows” file to my user directory I failed to include the BIN file highlighted below. Once I put that file there it worked fine.

Sorry for any bother.



1 Like

@NRobinson2 Thanks for reporting back! FYI, if you add the arduino-cli to your PATH you should not need to move the files around, just double click on flash_windows and you’re good to go.

@NRobinson2 Thank you for clearing this out. I just had the same issue and resolved it with your help. Cheers! :smiley: