Computer not recognising Silicon Thunderboard

hi there, I am in the tinyML summit and the thunderboard is not recognised by my computer, but it is connected and the blue LED light is flashing - any thoughts?

Hi @Sicily_F

Do you have any error output on your serial terminal? Also have you installed the Edge Impulse CLI?


hi jenny, i have but there is no error

Hi @Sicily_F,

Please try flashing the Silicon Labs Thunderboard firmware onto your device (, you may need to do this via the Silicon Labs Simplicity Studio software:

Also, please try and pressing and holding the RESET button on the Silicon Labs board, and then plugging it into your computer


hi Jenny,

I tried the reset button, but it is still not recognised by the computer, I have downloaded the .bin file, but I can’t flash it without my computer recognising it? Or maybe I’m confused

Can you try installing the Simplicity Studio to see if that software recognizes your board?

Also try another USB cable, another USB port on your computer, etc.

is there a link for the Simplicity Studio? Apologies I can’t find it - I have tried other cables

Simplicity Studio download:

It’s taking a while to download, will the recording be available?

Yes a recording should be available on the TinyML Summit website

hi jenny ok, it’s still not recognised in simplicity studio so will try restarting and catching up later

I have the same problem, I did all of the above steps, still cant see the usb drive.

@Sicily_F @lawga,

If this issue persists, I recommend contacting Silicon Labs about this issue directly through their support forums and support channel here: &


Also make sure you have JLink installed:

@jenny I tried all of the above with no luck, and I already submitted a ticket to silabs.

@jenny @Sicily_F a 4th cable did the magic, seems like I’ve been using a power-only micro-USB cable! Hope this will help someone!


Really glad to hear that @lawga - I had exhausted all of my troubleshooting options! :stuck_out_tongue:

1 Like