CLI Installation Issues Late 2021 for Portenta

I use multiple windows/linux computers at home and at school (school computers are typically locked down so installations are always an issue) and I have never had a smooth experience installing the EdgeImpulse client. I always think it is my own issues with following directions, but I just tried installing the client with my GearbotsBC after school tech group and no one could get a smooth installation completed.

We did get the arduino-cli and EdgeImpulse firmware/bootloader installed, by unzipping the arduino client in a folder and putting the EdgeImpulse firmware in the same folder.

We also got the “Connect using WebUSB” working which I had problems with before. The trick is that the EdgeImpulse bootloader must first be installed on the Portenta before the WebUSB works. We checked, uninstalled it and WebUSB did not work. Being able to see the Portenta Vision Shield Grayscale camera data live is a huge bonus!

The installation issues we had are:

  1. The arduino-cli path, anyone know an easy, command line way to set this up? Getting kids to change their Environment Variables is not always a good thing.

  2. The edge-impulse-cli expects arduino-cli 0.13 but arduino-cli is now about 0.19 not sure if that is an issue, but we installed arduino-cli 0.13

  3. Python3 is an easy install

  4. Node and npm are an easy install

  5. On windows the edge-impulse-cli path seems to causes issues, even when it looks correctly setup in windows Environment Variables.

  6. After getting the path working (may have needed a reboot), I am getting lots of errors with the bindings.node when running edge-impulse-daemon.

We are fine since webUSB which works great, but curious if other people with limited access to windows PATHs are having similar issues.

One thing that is a bit disorientating is after installing edge-impulse-cli there is no edge-impulse-cli command to check if the installation worked. You have to run edge-impulse-daemon