on Rpi always returns bounding box found?

I have a small test project to find daisy flowers in grass. I’ve generated the model and deployed to an R Pi 3 B+ using a webcam. When using the runner program it appears to work as expected (model FOMO MobileNetV2 0.1). I’ve also downloaded the python sdk but when I run the script it always returns a bounding box over the whole image, with no daisy in the frame. This is also true of

“Found 1 bounding boxes (13 ms.)
Daisy (1.00): x=0 y=0 w=96 h=96”

What am I doing wrong here?

Project ID:

Context/Use case:
Just a test use, to get a feel for things.

Ah, I figured it out myself. The original model was poor or maybe even corrupt and I had assumed that the model was updating each time I changed it online when clearly it wasn’t. Running “edge-impulse-linux --clean” and shifting to a cloned project finally showed me that the model file wasn’t changing, as the label hadn’t changed.

I now have an updated model after deploying the model using Arm and running " chmod +x path-to-model.eim".

1 Like

Hello @BombusT,

Glad that you solved your issue,