Classification failed

Hello @janjongboom,
I have been using your Edge Impulse platform so far. It has been awesome. I recently built an audio recognition system with two classes which worked well. However, when I increased my data class to 4, I got the following error:

Failed to load
Classification failed(err code: -3)

Hey @George_i, I just did a quick test on your project and I can classify data… How long is the sample that you’re uploading? And does it show up afterwards in the list of samples under ‘Live classification’? If so, could you leave it there and not remove the sample? That would let me check what might be going on.

^ This is from 2 seconds of audio data I uploaded.

I sampled 10sec of data for each class. Training on the web platform is fine. But, inference on mobile browser failed.

Ah! Now I get it. There seems to be something wrong with our allocator:

Arena size is too small for activation buffers. Needed 28000 but only 17900 was available.
printChar — Script Element 1:2:52050

Can you temporarily change the window size to 1000 ms. in the “Create impulse” screen? That will allocate a smaller tensor arena.

I have the same issue. My code works really fine with 3000ms window size, however even though I tried to reduce it 1000 ms I have same classification error both in my phone and in Arduino BLE 33 Sense. What should I do?
Thanks in advance.

****Ok it works fine right now with 2000 ms.

@selinay What’s the error that you got on the Nano 33 BLE Sense?

Arduino Ble 33 Sense also gives this error: Classification error (-5) as my mobile phone gives for my project named CoughDet2. Its window size is 3000 ms. When I try for my Selinay-Project1 named project with a window size 2000ms it is working.
image

@automatiek This is 3 seconds audio on Nano 33 BLE Sense, any idea why we’d write outside the feature buffer?