Cannot find any webcams in Raspberry Pi 3B +

Hello sir I was trying to run this code
I was using RaspberryPi 3B + after running edge-impulse-loinux this showing me this following error
“To which project do you want to connect this device? ICEM / Autobilling
GST] checking for /etc/os-release ?
Select a microphone or run this command with --disable-microphone to skip sel ection) bcm2835_hdmi - bcm2835 HDMI 1
[SER] Using microphone hw: 0, 0
Failed to initialize linux tool Error: Cannot find any webcams, run this command with --disable-camera to skip selection
at /us/lib/node_modules/edge-impulse- linux/build/cli/linux/linux. js:442:23”

My camera is working properly but still this error is showing please solve this problem…

Hi @Niraj_ICEM welcome to the forum,

Hello sir I was trying to run this code

What code? :smiley: Also what architecture is this 32bit or 64bit?

Debugging steps are in the associated documentation for the pi4, it should work for pi3 too, did you try all of this?

  1. Check Camera Configuration: Verify that the camera is enabled in the Raspberry Pi configuration settings. You can do this by running:


sudo raspi-config

Then navigate to Interfacing OptionsCamera and make sure the camera is enabled. Reboot the Raspberry Pi after making any changes.
2. Test Camera Functionality: Run a test to ensure that the camera is working properly. You can use the raspistill command to capture an image:

raspistill -o test_image.jpg

If the command executes without errors and captures an image, it indicates that the camera module is functioning properly.
3. Check for Camera Recognition: Verify that the camera is being recognized by the system. You can use the following command to list the connected video devices:


ls /dev/video*

If the camera is detected, you should see /dev/video0 or a similar entry listed.
4. Update System and Dependencies: Ensure that the Raspberry Pi’s operating system and packages are up to date. Run the following commands to update the system:

sudo apt update
sudo apt upgrade
  1. Check Camera Permissions: Make sure that the user running the Edge Impulse application has the necessary permissions to access the camera. You may need to adjust the permissions using chmod or by adding the user to the appropriate group.



Sir its autobilling system using ai code

I am 64 bit operating system but still it showing same error
like firstly I was trying with 32 bit then I know that edge impulse will not work with 32-bit so I have reinstall the operating system to 64bit at the time of 32-bit raspistill is working properly I am able to take pictures but in 64biit this command is no long in used libcamera its working properly but still same error message is showing please help me with that

I have check camera configuration also

Hi @Niraj_ICEM

I dont see any confirmation of the debugging steps tested, please follow the guide and post the output of the commands I shared.

FYI: Please review our Fair Usge Policy:

If this “autobilling system using ai code” is for commercial usage you will need to speak to our sales and get on the appropriate payment plan.




can you share me how to debug
This project I am trying to execute AutoBill -

pi@raspberrypi:~ $ edge-impulse-Linux

Something went wrong installing the “sharp” module

Cannot find nodule ‘…/buitd/Release/sharp-Vinux-arm64v8.node’

Require stack:

  • /usr/1ib/node_modules/edge-impulse- Linux/node_nodules/sharp/Lib/sharp-js

  • /us/11b/node_modules/edge-impulse-Linux/node_sodules/ sharp/Lib/constructor.js /ust/lib/node_modules/edge-impulse-Linux/node_nodules/sharp/lib/index.js
    Possible solutions:

  • Install with the -verbose flag and look for errors: *npa install --ignore-scr ipts=false •verbose sharp®

  • Install for the current runtine: *npm install --platformLinux --archears sh



Now this error is showing
I have download that module that shown in command but still it showing same error please help me with that.

Hi @Niraj_ICEM

You would be best to ask on the hackster project, the issues you are facing are not related to edge impulse, but the sharp nodejs module.