Arduino Sense 33 REV2 stuck during second audio sampling iteration

When recording audio date my Arduino Sense 33 R2 always timeouts during the second iteration. It will not sample again until the USB cable has been disconnected. Rebooting, flashing the firmware and different USB cables or ports do not solve the issue. Sampling other sensors does not produce the issue.
I don’t know if it’s related, but Failed to parse snapshot line [ ] is printed 3 times when starting edge-impulse-daemon:

? Which device do you want to connect to? /dev/tty.usbmodem2101 (Arduino)
[SER] Connecting to /dev/tty.usbmodem2101
[SER] Serial is connected, trying to read config...
Failed to parse snapshot line [  ]
[SER] Retrieved configuration
[SER] Device is running AT command version 1.8.0

Failed to parse snapshot line [  ]
Failed to parse snapshot line [  ]
[SER] Device is not connected to remote management API, will use daemon
[WS ] Connecting to wss://
[WS ] Connected to wss://

Project ID: 327700

Context/Use case:
Steps to reproduce:

  • Go to Data acquisition
  • Start sampling the built-in microphone
  • The recording will be uploaded
  • Start sampling again
  • The process will block:
    The website hangs at "Sampling... (1s left)"
    Daemon hangs at "[SER] Sampling started"
  • Edge-Impulse daemon will print Timeout when waiting for > (timeout: 60000) AT+SAMPLESTART=Built-in microphone
  • edge-impulse-daemon will be unable to connect to the Arduino until it is reset

Hi @highbosom,

This may be a USB cable problem. Can you try a different USB cable and different USB port to see if that solves the issue?

i am having a similar issue for the nano 33 BLE accelerometers. the board works fine when using it to collect data, but when running the final deployment library on the board, it crashes as soon as the accelerometers begin to move. it’s not a cable issue.

Hi @shawn_edgeimpulse
Thank you for the response, but sadly that doesn’t solve the problem

Hi @highbosom and @jebay1,

Thank you for pointing out this issue. I tried on my Arduino and ran into the same issue. I have filed a bug with our engineering team.

1 Like

Glad to hear it’s not a hardware issue

any luck?
my code still freezes as soon as i start moving the wand
thank you!

Hi @jebay1 ,

The fix for this issue is merged in today, but will need some time (around a day) to be live on production.


1 Like

Hi, the fix is live on production.


Hi Arjan, I have updated the Arduino Nano Sense 33 r2 firmware, but the issue persists
Is there something else I should update?

Hi @highbosom

when you say that you updated the firmware you refer to the pre-built image or the public firmware repository for the nano ?


Hi @ei_francesco
This is the firmware I flashed

Hi @highbosom ,

I forgot to update it the binary, it should be in production soon. Meanwhile you can build and flash from the public repo.



Hi @ei_francesco

thank you for your help.

the code requires EI_CLASSIFIER_RAW_SAMPLES_PER_FRAME to equal 3, but in the library files that variable is set to 9. we updated the code to 9 and that seems to stop our wand (nano 33 ble sense) from freezing upon movement.

i have been updating the library to set it equal to 3.

building and flashing the latest firmware worked
Thanks for the support and fixing the issue!

Edit: the issue still occurs after a few sampling iterations. During the fifth iteration instead of the second one

Hi @highbosom

How long is the sample length ?


sample length is 1000 ms

ok let me check what is failing.

Hi @highbosom ,

I’m testing a new fix, I’ll keep you updated.


Hi @highbosom

the fix is on production, let me know if is working on your side.