Arduino Nicla Vision fails to deploy

Question/Issue: We have followed the Arduino Tutorial and are downloading the firmware from Edge Impulse using the Nicla Vision as the builder. Our model is the MobileNetV2 96x96 0.1 (final layer: 4 neurons, 0.1 dropout). This results in a model much smaller than any tutorial but when we load the firmware (either via terminal or OpenMV IDE), the blue light never turns off (ie, the self-test never completes). The only way I have gotten it to run is by creating a grayscale model and deploying/downloading the OpenMV Folder.

Project ID: gaidica-project-1

Context/Use case: We have four different objects we would like to be classified. Each object has 100 images associated with it and everything works fine until the deployment. Our images are on 96x96 resolution and we initially had 12 neurons, 0.15 dropout with a model size of 800KB. Arduino states that this has to be around 200KB so we dropped the amount of neurons to make the model 170KB but deployment still failed and we still experienced a crash. It’s unclear why we can’t get anything meaningful to work. I’ve also tried the MobileNetV1 model. We are able to reload the current firmware just fine, the device operates normally.

Hello @gaidica,

Could you provide more information about the error you have?
Are you using OpenMV IDE, Arduino IDE, the Edge Impulse generated firmware for the nicla?

Feel free to include a screenshot too if that helps to explain.



Hi Louis, I noted we are using OpenMV IDE. We’ve also tried the terminal to load the firmware. Also above, we are “downloading the firmware from Edge Impulse using the Nicla Vision as the builder”. There is no apparent error, just that any RGB model we create causes the Nicla to hang (blue light) and not execute the self-test.

It seems there should be a small repository of binaries known to work on the Nicla (or an option to share ours). Then we could easily determine if it’s our model or something else. We’ve tried this on Window and MacOS.