Arduino Model only outputs the first Label

I am not sure if this is a bug or I am doing something wrong. When I build my Arduino library from the deployment section, the classifier only predicts the first label with accuracy of 0.99609 in all the iterations. This was working fine till yesterday night.

The Live Classification section works as expected. The Arduino firmware also gives the wrong output.

Please help me out.

Hey @ravi_bhushan, which project is this on (I see that you have a bunch) and on which hardware target? I’ve just ran the Arduino export on one of our projects and that still works as expected on the Arduino Nano 33 BLE Sense.

Hi Jan,
Thank you for the prompt response.
It is “Accelerometer_foklift_move_stop v1 v3”.
I am running on Arduino Nano 33 BLE Sense.

@ravi_bhushan Did a quick test using static_buffer and one of your examples (image) and this returns:

Not sure if this is correct, but it definitely yields something different than what you see. I see that you’re retraining now, but @aurel could you have a look in the morning if this persists?

Hi @ravi_bhushan,

I tried your library on my Arduino and manage to classify different labels.
One quick remark on your dataset: I saw you recently added new samples but with new labels, 7 in total. Are they all different movements? Ideally you’d like to have a uniform dataset, some labels have 10 times more data than others which can lead to overfitting one particular label.


Hi @aurel and @janjongboom thank you for your comments and response. I will add more data.

So, I created a new version of the project as “ACCELEROMETER_FOKLIFT_MOVE_STOP V1 V3 V1” and downloaded the Arduino library. It worked as expected.

Regarding the project “Accelerometer_foklift_move_stop v1 v3”. I am not getting the error which I mentioned earlier. So, I am not sure why that error occurred.

But, for now, the issue for which I created this topic seems to be solved.

1 Like