Arduino-cli flash not in PATH

So I just receive a nano 33 ble sens today and I am at the flashing the firmware part.
I’ve tried installing it by hand then with git at local/bin added to PATH each time, arduino-cli showed it was installed and working. I always run my cmd in admin mode, even the bat files.
But when it comes to running the bat file from the flash firmware tutorial on edgeimpulse I always get this message, even if I navigate to the folder to run the bat in cmd and then cmd run arduino-cli in the same consol:

‘where’ is not recognized as an internal or external command,
operable program or batch file.
Cannot find ‘arduino-cli’ in your PATH. Install the Arduino CLI before you continue
Installation instructions:
Press any key to continue . . .

I tried to find another way to flash it without using the bat file. Renamed the bin file to ino, but nothing worked so far.
I did try the command line on the official 33 BLE sense repository
./ --build
./ --flash
But I’m not sure if it worked.

Can anyone help me please?

Well, idk why I did everything except to look for that first line “‘where’ is not recognized”.
I found this and finally resolved this issue: