ArduCam RP2040 Failed to be recognized by Windows When Running Edge Impulse Firmware

Hey, I recently started using Edge Impulse for a project and I wanted to run it on my ArduCam Rp2040(Article Here: Arducam Pico4ML TinyML Dev Kit - Edge Impulse Documentation ). I followed the directions to flash the device with the Edge Impulse firmware and once the device is flashed with the firmware, I get notifications from windows saying that the device is not recognized. This is causing the edge impulse software to not be able to connect to the device. I have tried using the windows version of the Edge Impulse software along with running it in a Ubuntu VM through VirtualBox and I run into the same issue post flashing the device. Is there a way around this issue of the device not being recognized? Thanks.

Hello @BKearney,

Could you try with another usb cable perhaps?

If this does not work, I’ll dig into other solutions.



Hey, thanks for the response. I am still getting the issue after trying with a different usb cable. I am following the instructions on this page: Raspberry Pi RP2040 - Edge Impulse Documentation and after I drag the file over onto the rp2040 then wait for it to flash then I unplug it and plug it back in. This is where the error that I have attached below pops up. Thanks

I have also attached the screenshot of the error in Ubuntu(running in virtualbox) when I try to connect the rp2040. Thanks