Generate Features Stuck

I am trying to run the Generate Feature task on a job, but it repeatedly hangs up on “Still waiting for job to be scheduled…”. It appears no matter how long I leave it, when I return and the console attaches to the job, it is just stuck waiting to be scheduled. Of course, this is now stopping any progress on the project, and it happens regardless of how many times I attempt to cancel and restart the Generate Feature task. I’ve tried a couple times over the past few hours, and it never actually gets scheduled.

Please advise, thank you!

Project ID: 159295, Job ID: 5864080

1 Like

I’ve got the same issue (project ID 142125). I also saw some kind of CloudFront error message earlier in the feature preview area, so it seems like maybe there’s a service interruption.

Hi this is problem

The same error apears to me too. Project ID: 177122
Edit: It seems everything is stucked. Including Build, Versioning.

1 Like

I have the same error. I request anyone to suggest a solution.

Hi all, all jobs indeed are pending and none are scheduled. For some reason monitoring didn’t pick this up so didn’t wake anyone up last night. We’re investigating right now.

@austingreene @brianatcarrot @norik.badalyan @ioanF @urbija


Thank you @janjongboom

This issue has now been resolved, see All jobs: 'Still waiting for job to be scheduled...' - #3 by janjongboom for some background.


Thank you! Responsiveness like this is one of the reasons I’m pushing our broader team to look into using Edge Impulse!

1 Like