Edge impulse cli installtion issue in linux environment

Below are the outcome
emqos24@emqos24:~/Desktop/himax/sourcecode/testcode/ei-install-scripts$ . ./install-linux.sh
[sudo] password for emqos24:
Hit:1 http://in.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://in.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://deb.anydesk.com all InRelease
Hit:4 https://dl.google.com/linux/chrome/deb stable InRelease
Hit:5 https://deb.nodesource.com/node_14.x focal InRelease
Get:6 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Hit:7 http://in.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:8 https://apt.kitware.com/ubuntu focal InRelease
Hit:9 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu focal InRelease
Fetched 114 kB in 6s (17.6 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
g++ is already the newest version (4:9.3.0-1ubuntu2).
gcc is already the newest version (4:9.3.0-1ubuntu2).
make is already the newest version (4.2.1-1.2).
python3 is already the newest version (3.8.2-0ubuntu2).
python2 is already the newest version (2.7.17-2ubuntu4).
sox is already the newest version (14.4.2+git20190427-2).
build-essential is already the newest version (12.8ubuntu1.1).
curl is already the newest version (7.68.0-1ubuntu2.7).
ffmpeg is already the newest version (7:4.2.4-1ubuntu0.1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
npm prefix = /home/emqos24/.npm-global
Installing edge-impulse-cli…
npm WARN deprecated request-promise@4.2.4: request-promise has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
npm WARN deprecated request@2.88.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated @zeit/dockerignore@0.0.5: “@zeit/dockerignore” is no longer maintained
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details.
npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
/home/emqos24/.npm-global/bin/edge-impulse-blocks -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/blocks.js
/home/emqos24/.npm-global/bin/edge-impulse-daemon -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/daemon.js
/home/emqos24/.npm-global/bin/edge-impulse-uploader -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/uploader.js
/home/emqos24/.npm-global/bin/edge-impulse-data-forwarder -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/data-forwarder.js
/home/emqos24/.npm-global/bin/edge-impulse-run-impulse -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/run-impulse.js
/home/emqos24/.npm-global/bin/eta-flash-tool -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/eta-flash-tool/flashtool.js
/home/emqos24/.npm-global/bin/himax-flash-tool -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/himax-flash-tool/flashtool.js
/home/emqos24/.npm-global/bin/edge-impulse-framebuffer2jpg -> /home/emqos24/.npm-global/lib/node_modules/edge-impulse-cli/build/cli/framebuffer-to-jpg.js
npm WARN tsargs@1.4.1 requires a peer of typescript@^3.1.6 but none is installed. You must install peer dependencies yourself.

  • edge-impulse-cli@1.14.5
    updated 1 package in 58.125s

Maybe a dumb remark but have you tried to close and reopen your terminal and try again?

you want me to try

above once again by reopening terminal…?

No just quit your terminal and try again the edge-impulse-daemon command to see if it can find the command.


NOT worked, still issue persists…

Alright, then maybe you can try some of @janjongboom’s tips from here: Edge-impulse-daemon: command not found


Not getting
above path

tried to create by using
ln -s /home/emqos24/.npm-global/bin /usr/local/bin/edge-impulse-daemon

command but got error.

Added to path also but same issue.

Can you add your /user/local/bin too ?

Same issue…

Can you try with sudo? sudo edge-impulse-daemon it should be required though

Oh and after exporting your PATH, maybe you need to source your bashrc:

source ~/.bashrc

Or close your terminal and open it again, that should do the same as source :slight_smile:

i have reopen terminal
but same issue.

And what does it give when using sudo?

Hello louis,
Is it possible to have online session and resolve the issue.

Hi @prashant.s,

Sorry I probably won’t have time for a one-to-one session in the coming days…

what is the output of the following command?

npm config get prefix


And could also you post the following commands output please?

$ npm uninstall edge-impulse-cli -g
$ npm install edge-impulse-cli@latest -g