Different processing blocks input to different models

I have a NN classifier and a k-means model, but different input data into each. I tried to make two separate processing blocks and then only checking the box within the model for data I’d like to go into each model, but the second model (k-means) still only gets the input from the processing block that is also passed into the NN classifer. I have tried rerunning and renaming the processing blocks, and still have no luck.

I tried this with a completely new project and switched the order of the two models, and confirmed that the same bug happens where the second model gets the input data from whatever the first model has selected. Are there any workarounds in the meantime?

Hi @jarnold1,

Can you please share your project ID?


Here is the project ID: 199417

@aurel I wanted to follow up on this and see if there was any work around for this in the meantime.


This Impulse trained for me.

For example, if your using an IMU, I assume you want to Classify motions in the X/Y plane and movements along the Z-axis reported as an anomaly.

I didn’t deploy to a device and test since my input data would need to be collected conforming to the example mission above.

Yes this is similar. I have two flatten processing blocks (with different names) with different features checked. Mine also does train, but the data that is input is not correct. In the two projects I’ve tested this in, whichever is the lower learning block gets the same inputs as the upper learning block.

For example, in the configuration you have, I would see that the NN classifier has half as many features input to the network as expected (presumably because accZ is the input rather than AccX,Y which is selected). If I switch the order of the learning blocks, I can more clear see the issue since in the Anomaly Detection impulse design page after this one, I would see options for the wrong processing block.

Please let me know if I can provide any more clarification.

@jarnold1 Your response so far I think is clear enuf. It will take me some time for me to work thru a working example to reproduce your concerns. Can you make me a collaborator on your project so I can see what you are seeing. Else if your data is proprietary create a dummy project with the bare minimum that reproduces the issue and make me a collaborator or make it public and I can clone it.

In the mean time can @aurel help or provide examples with an Impulse containing multiple Learning Blocks and multiple Processing Blocks with different inputs feeding the blocks?

Hi @jarnold1,

I managed to reproduce the issue, I’ll check with our studio team when we can have a fix.



Hi @aurel,

I wanted to check in on this to see if there was any kind of work around while the studio team looks into a fix.

Hi @jarnold1,

This issue has been fixed. Let me know if it looks good on your project.


Hi @aurel,

I now get this error when trying to export as a C++ library:

Creating job... OK (ID: 7740317)

Scheduling job in cluster...
Job started

featureCount for all learning blocks should be the same, but was: [30,8]

Creating templates failed

Job failed (see above)

So now I can run the training with the correct features but it seems some check in the C++ exporter fails. Please let me know if you need any more information on this and the timeframe for fixing this bug.

@aurel I wanted to follow up on this and see if there is any workaround for now.

@aurel What is the expected timeline for a resolution to this bug?